Nero BurnRights - Nero BurnRights

Nero BurnRights

Under Windows 2000 and Windows XP there must be a way to handle the security aspects of CD/DVD recording. CD/DVD pre-mastering software like Nero must be able to send SCSI/IDE commands to CD-ROM/DVD-ROM drives or CD/DVD recorders. However, from the operating system's point of view, being able to send SCSI/IDE commands to devices is a huge security problem, because software could use the SCSI/IDE commands to format the hard disk, read other user's data or create other severe problems. That is why Microsoft decided to allow low level driver access only for programs running with administrator rights.

Now, let's assume the situation of a Windows 2000 or Windows XP PC in a network environment and with many different users. Security considerations make it absolutely impossible to grant administrator rights to all users. So firstly, there must be a way to allow CD/DVD recording for non-administrators and being able to decide which users may record CD's/DVD's and which users may not.
The way to solve this situation is to install Nero BurnRights. After Nero BurnRights has been installed, the system administrator can assign a specific group the rights to record CD's/DVD's on the system. If an administrator wants to allow or disallow CD/DVD recording rights for certain users, it is enough to make the user a member of this group or to remove the user from the group. If everybody should have the right to record CD's/DVD's, the recording rights can be assigned to everybody.


Nero BurnRights - Installation

Installation

If you want to install Nero BurnRights you must be member of the administrator group. Please shut down all other applications before you execute the installation file.

The installation is pretty simple, because all steps will be accomplished automatically. You will be informed if problems occur. Please follow the steps in this description to succeed. You can assign additional groups that should have the right to burn, when Nero BurnRights is running as soon as the installation process is finished. A restart for this system is mandatory to finish the setup.

You can learn more about installation in the following sections:

  • Installation directory
  • When NeroSVC or NeroSecurity is installed already
  • Installation via script


Realizing Nero BurnRights on your system

Nero BurnRights will show up as icon in the control panel after executing the installer file. It will give you these three options:

  1. Only Administrators will have burnrights.
    (This is the default setting of Windows 2000 and Windows XP)
  2. All declared users will be able to burn
  3. Only administrators and a selected group of users will have the right to burn.
    (This option is not available on XP home edition)
    This option distinguishes between usergrous, which are allowed to burn, and usergrous, which are not allowed to burn.
    The default name for the group with burnrights is "Nero".
    Any user can be added to this 'privileged' group anytime, if you proceed following steps:
    Click on:
    start->settings->administration tools->computer management->local users and groups->groups
    Choose the group 'Nero' and add the preferred user to this group.

ANNOTATION:

  • Below you will find the description of what to do in case the group has a different name.
  • The group will be set up automatically, if it wasn't there beforehand.


How to uninstall Nero BurnRights

Nero Burnrights can be uninstalled like every other software that is listed in start -> settings -> control panel -> software Select Nero BurnRights and press remove.


Additional notes regarding Nero BurnRights

Installation

Renaming the groupname of the group that has burnrights

Problems


Nero BurnRights - Additional notes regarding Nero BurnRights - Installation

Installation

Installation directory

When NeroSVC or NeroSecurity is installed already

Installation via script


Installation directory

The regular installation directory of Nero BurnRights is called NeroBurnRights. If Nero is installed already, the installation directory of Nero BurnRights will be on the same level.
e.g.
If Nero is on D:\burning\ahead\Nero
Nero BurnRights will be installed in the directory:
D:\burning\ahead\NeroBurnRights

In case Nero is not installed Nero will be installed in the subfolder ahead\NeroBurnRights of the default program directory.
Is C:\Program Files the default program folder the Nero BurnRights will be installed in C:\Program Files\ahead\NeroBurnRights

If you don't like the path it's going to be installed in as seen in a. & b. You can make up your directory selection.
Use this steps therefore:
Invoke the NeroBurnRightsInstaller with following parameter:
/path=<requested path for NeroBurnRights>

NOTE:
If there is a blank in the name of the path you have set quotation marks in the beginning and the end.
e.g.:
"/path=D:\My Programs\ahead\NeroBurnRights"


When NeroSVC or NeroSecurity is installed already

The Installer of Nero BurnRights will notice a previous installation of this tools and point out possible difficulties and how to resolve them.

NOTE:

Uninstall NeroSVC or NeroSecurity only if your asked to do it, because NeroBurnRights will adopt the recent group which has already burnrights.

A problem could be that a group, which had the right to burn, will keep this right, even if it's assigned as group without burnrights in Nero BurnRights. You will find more information at section Problems

The administrator will not be informed about problems, if the /silent install was selected. Please look up b.


Installation via script

This issue is only interesting for network administrators.
Options for silent installation:

  1. No user specific information is required.
    Parameter:
    /silent
  2. You can select the requested group that should have burnrights, when you following the steps below.
    NOTES:
    Parameter:
    /burnrights:admin
    only members of the administrator group can burn
    /burnrights:all
    all users which are declared on this local system will be able to burn
    /burnrights:group=<any groupname>
    only members of the administrator group and the selected group will be able to burn
    NOTE:
    If there is a blank in the name of the group you have set quotation marks in the beginning and the end.
    e.g.
    "/burnrights:group=nero burngroup"
  3. You can also use the way described in Installation directory Section c to set up the directory.
    /path=<requested path for Nero BurnRights>
    So all the below listed parameters are supported:
    /silent
    /path=<requested path for Nero BurnRights>
    /burnrights:admin
    /burnrights:all
    /burnrights:group=<any groupname>


Renaming the groupname of the group that has burnrights

Nero is installed and the group 'Nero' should not be the one with burnrights.

  1. You can change the present groupname if the group, which should have burnrights, doesn't exist at the moment. Nero BurnRights will recognize the renamed group.
  2. If the requested group already exists:
    • Please start Nero BurnRights and select the administrator group as group with burnrights. Now close the program.
      Do not reboot the system.
    • Now start regedit and go to
      HKEY_LOCAL_MACHINE\SOFTWARE\ahead\Nero BurnRights
      Add a new string (REG_SZ) entry.
      Name it:
      ModNeroGroupName
      And enter the requested groupname.
    • Now start Nero BurnRights. Now the entered name will be taken over.


Problems

  1. NeroBurnRights is installed correctly but you still can't burn. Please check if nero or the nero api based product was started in the compatibility mode.
    Cause:
    If the product (e.g. Nero) will be started in the compatibility mode,then the burnrights set by Nero BurnRights will not be active.
    Solution:
    Don't start Nero or the Nero API based product with enabled compatibility mode.
    Where can you find this setting?
    Rightclick the exe-file -> properties -> compatibility -> compatibility mode
  2. It's possible that a group can burn even without having burnrights.
    In this case Nero BurnRights gives you the option to handle this.
    Please start Nero BurnRights and open the property page "Advanced Options". Now press "Reset Burnrights".
    Cause:
    Nero BurnRights does not remove any current active burnrights to members of a specific group.
  3. When you start nero or a product based on nero API, you might get the error below:
    The setting 'Devices: Restrict CD-ROM access to locally logged-on user only' was changed. This why you have to reset the burnrights, so they will be initiated again.
    It also can happen that you loose your burnrights.
    Solution:
    Please start Nero BurnRights and open the property page "Advanced Options". Now press "Reset BurnRights". After the reboot the problem should be fixed.
  4. Burning is only possible when the system is within a domain, but not if it's used as local machine. This behavior is caused by the GPO (group policy objects) defined in the domain. This policy also includes in your network environment the setting 'Devices: Restrict CD-ROM access to locally logged-on user only'. Now, if your machine is within a domain, this setting is enabled. But when you run it only locally it's disabled.
    Solution:
    Start the this system locally, so the GPO is not involved. Than you have to set the option 'Devices: Restrict CD-ROM access to locally logged-on user only' like the GPO this setting pretends.
    Where ist this setting?:
    Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy -> Security Options.
  5. You're working on Windows 2000/XP and you're getting an error message stating that Nero BurnRights will only run on Windows 2000/XP.
    Cause:
    The Nero BurnRights installer has an advanced operating system detection, because there is software which is emulating other Operating Systems so that the correct Operating System will not be detected correctly.
    Under Windows 9x/ME exists within the following key
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion
    the following entry called
    VersionNumber
    Some other programs can only be installed if they add this entry in Windows 2000/XP like in Windows 9X/ME.
    But the Nero BurnRights Installer will interrupt the installation process if this entry also exists on Windows 2000/XP.
    Solution:
    Rename the mentioned entry "VersionNumber" into "VersionNumber2".
    Repeat the installation and name this entry back after installing Nero BurnRights successful.
  6. Nero BurnRights is not working. People who are not administrator don't have enhanced rights.
    If you install Nero BurnRights by using another software which only records changes (within registry or files) on your system, this is why it won't work.
    One example of such software: Autoinstall (AI) packages generated with Ghost.
    Each CD drive has a undisputed ID. And because Nero BurnRights accosts all drives straigthly during the installation, it will not work using other software like mentioned before.
    Reason:
    The drives and their corrosponding IDs are not the same like on the system Nero BurnRights installation was executed and recorded originally.
    Solution:
    Install Nero BurnRights directly on the requested system
    or
    Start Nero BurnRights, select Administrator, apply this (don't restart) and afterwards you can choose the requested group and restart the system.